Affinix Analytics Impacted by Microsoft Outage

Incident Report for Affinix - Public

Resolved

Fabric customers may have experienced delays or intermittent access issues due to increased request traffic impacting part of the infrastructure. Mitigations have been applied globally, and the service has largely recovered. We are continuing to closely monitor service health to ensure full stability. The next update will be provided by 05/19/2026 12:00 PM PDT.

Notification DateTime: 05/18/2026 07:37 AM PDT

Regions: All
Posted May 18, 2026 - 18:30 CDT

Update

Microsoft updated their status page, and there is currently a Global Power BI outage.
https://support.fabric.microsoft.com/support/
Posted May 18, 2026 - 12:36 CDT

Monitoring

Power BI is currently unavailable due to a Microsoft Outage. We will monitor for updates from Microsoft.
Posted May 18, 2026 - 09:27 CDT
This incident affected: Analytics.