Affinix ATS and greatjob.net outage - AWS Global Outage

Incident Report for Affinix - Public

Resolved

Affinix ATS is not operational following resolution of issues within ATS.
Posted Oct 20, 2025 - 05:27 CDT

Monitoring

Affinix ATS including greatjob.net careers sites is currently down. Amazon Web Services (AWS) is currently suffering a major global outage which has impacted many global companies.

We are monitoring the situation and will advise when services have been restored.
Posted Oct 20, 2025 - 03:59 CDT
This incident affected: Career Portal and Core Services.